Kubernetes 兼容性

Cilium 与多个 Kubernetes API 组兼容。有些是废弃的或测试版的,可能只在 Kubernetes 的特定版本中可用。

所有列出的 Kubernetes 版本都经过 e2e 测试,保证与 Cilium 兼容。本表中未列出的旧版 Kubernetes 不支持 Cilium。较新的 Kubernetes 版本,虽然没有列出,但将取决于 Kubernetes 提供的后向兼容性。

Kubernetes 版本 Kubernetes NetworkPolicy API CiliumNetworkPolicy
1.16, 1.17, 1.18, 1.19, 1.20, 1.21, 1.22, 1.23 networking.k8s.io/v1 cilium.io/v2 有一个 CRD

Cilium 在 Kubernetes 中使用了一个网络策略的 CRD。这个 CRD 的模式验证可能会有变化,它可以验证 Cilium Clusterwide Network Policy(CCNP)或 Cilium Network Policy(CNP)的正确性。

CRD 本身有一个注解,即 io.cilium.k8s.crd.schema.version,有模式定义版本。默认情况下,Cilium 会自动更新 CRD 及其验证,使用较新的版本。

下表列出了所有的 Cilium 版本和它们预期的 schema 验证版本。

Cilium 版本 CNP 和 CCNP Schema 版本
v1.9.0-rc0 1.22.1
v1.9.0-rc1 1.22.2
v1.9.0-rc2 1.22.2
v1.9.0-rc3 1.22.3
v1.9.0 1.22.3
v1.9.1 1.22.3
v1.9.2 1.22.3
v1.9.3 1.22.3
v1.9.4 1.22.3
v1.9.5 1.22.3
v1.9.6 1.22.4
v1.9.7 1.22.5
v1.9.8 1.22.5
v1.9.9 1.22.6
v1.9.10 1.22.6
v1.9.11 1.22.6
v1.9.12 1.22.6
v1.9.13 1.22.6
v1.9.14 1.22.6
v1.9.15 1.22.6
v1.9.16 1.22.6
v1.9 1.22.6
v1.10.0-rc0 1.23.1
v1.10.0-rc1 1.23.2
v1.10.0-rc2 1.23.2
v1.10.0 1.23.2
v1.10.1 1.23.2
v1.10.2 1.23.3
v1.10.3 1.23.3
v1.10.4 1.23.3
v1.10.5 1.23.3
v1.10.6 1.23.4
v1.10.7 1.23.4
v1.10.8 1.23.4
v1.10.9 1.23.4
v1.10.10 1.23.4
v1.10.11 1.23.4
v1.10 1.23.4
v1.11.0-rc0 1.24.1
v1.11.0-rc1 1.24.1
v1.11.0-rc2 1.24.2
v1.11.0-rc3 1.24.2
v1.11.0 1.24.2
v1.11.1 1.24.3
v1.11.2 1.24.3
v1.11.3 1.24.3
v1.11.4 1.24.3
v1.11.5 1.24.3
v1.11 1.24.3
latest / master 1.25.4
上一页
下一页